Latencies fetching advertising data
Incident Report for DataHawk
Resolved
This incident has been resolved.
Posted Jul 31, 2022 - 08:08 UTC
Identified
Some advertising accounts may face latencies in getting data during the last days.
Posted Jul 29, 2022 - 19:00 UTC
This incident affected: Data (Amazon).