Issue with today's product data following changes on Amazon pages
Incident Report for DataHawk
Resolved
This incident has been resolved.
Posted Dec 22, 2021 - 16:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 22, 2021 - 14:35 UTC
Investigating
We have identified an issue in today's product data, including some prices wrongly reported being at $400. We are actively working on resolving it and correcting the associated data. We will send an additional update in 2 hours.
Posted Dec 22, 2021 - 12:40 UTC
This incident affected: Services (Web Application) and Data (Amazon).